Service BetaSeries.com : corrections apportées

[ Pages : 1 2 3 4 ]

← Page précédente | Page suivante →

Bonjour,

Je viens de mettre à jour mon Kodi en version 17.1, j'avais depuis longtemps une beta de la 17. N'ayant plus l'occasion de l'utiliser.
Avec ce dernier j'utilise l'extension "service.betaseries.com" en version 1.0.8

Sauf qu'en lançant Kodi après la mise à jour, j'ai eu des erreur du script. Je suis passé en mode debug pour loguer les erreurs.
Je suis développeur, mais je ne connais pas Python, après quelques heures j'ai finalement réussi à corriger les erreurs de syntaxe (il semble qu'il y ait maintenant un contrôle de script python dans kodi) les erreurs concernés la partie "movie" dernièrement ajoutée.

Il reste une erreur mais ne maîtrisant pas suffisamment je ne vois pas comment la corriger :

17:44:44.906 T:6872 WARNING: CPythonInvoker(1, C:\Users\Vince\AppData\Roaming\Kodi\addons\service.betaseries.com\betaseries.py): the python script "C:\Users\Vince\AppData\Roaming\Kodi\addons\service.betaseries.com\betaseries.py" has left several classes in memory that we couldn't clean up. The classes include: class PythonBindings::XBMCAddon_xbmc_Monitor_Director,class PythonBindings::XBMCAddon_xbmc_Monitor_Director

Si quelqu'un peut continuer, ou comment fournir la version que j'ai corrigé, merci de me le dire.

Membre depuis le 20 April 2013 — 2 messages

Moi aussi j'ai un problème avec l'Agent BetaSeries (et j'ai l'impression que conan76 a réussi à aller un peu plus loin que moi). Depuis quelques jours, l'agent a soudainement décidé d'arrêter de fonctionner et ne marque plus les épisodes comme lus. Je suis sous Kodi 17.0 et n'ai pas fait de mise à jour ni de modifications avant que l'add-on arrête de fonctionner.

J'ai la version 1.0.7 installée et le repository Betaseries indique qu'une mise à jour vers la version 1.0.8 existe. Mais lorsque j'essaie la mise à jour, j'ai des erreurs dans le log Kodi et la mise à jour ne se fait pas. Et je ne retrouve pas la version 1.0.8 à installer manuellement.

Je n'avais pas envie d'ouvrir un autre sujet concernant ce problème, parce qu'il se peut que la cause soit la même.

S'il y a besoin de plus de détails/logs/etc. n'hésitez pas à me demander.

Membre depuis le 5 May 2014 — 16 messages

@conan76, apparemment ton erreur peut-être ignorée car ça pourrait provenir d'un bug interne à Kodi: http://forum.kodi.tv/showthread.php?tid=307508

Du coup je veux bien ta version corrigée du 1.0.8 (ça m'évitera de passer du temps dessus moi-même).

En attendant une correction officielle...

Dernière édition le 15 May 2017 à 13:15

Membre depuis le 5 May 2014 — 16 messages

LarrxX a écrit :
@conan76, apparemment ton erreur peut-être ignorée car ça pourrait provenir d'un bug interne à Kodi: http://forum.kodi.tv/showthread.php?tid=307508

Du coup je veux bien ta version corrigée du 1.0.8 (ça m'évitera de passer du temps dessus moi-même).

En attendant une correction officielle...

La version 1.0.8 je l'avais pris sur le site (je l'ai mis à une époque dans mon dossier d'installe de mes softs)

J'ai mis le fichier à dispo ici : Juste le fichier betaseries.py

Tu peux comparer les fichiers.
au passage dis moi si ça corrige ton problème.

nota : il a toujours le problème de destruction de la classe

Membre depuis le 20 April 2013 — 2 messages

Maretoh
Modérateur

Pour avoir les corrections "officielles", je pense que le mieux est de reporter ça directement sur la page du plugin et/ou de poker les auteurs du plugin qui ne passent pas forcément sur le forum ;)
https://www.betaseries.com/wiki/Plugin%20XBMC

An episode a day keeps the doctor away.
Membre depuis le 12 October 2013 — 15065 messages

@conan76 moi la seule page que je connaisse pour télécharger le plugin est celle indiquée par @Maretoh. Elle pointe vers la version 1.0.7! Mais une recherche Google m'a permis de tomber sur le repository Git et récupérer la version 1.0.8 (mais c'est une gymnastique qui ne devrait pas être faite par le commun des mortels!).

@Maretoh merci pour l'info, mais j'avais l'impression que ce n'était pas trop réactif en lisant les commentaires sur le wiki, c'est pour ça que j'ai préféré poster ici. Je m'en vais de ce pas y poser un lien vers cette discussion.

Membre depuis le 5 May 2014 — 16 messages

Hello,

La version la plus éprouvée et la plus stable à ce jour est la 1.0.7, elle est compatible à 100% avec Krypton 17.x (nous utilisons les versions Kodi Nightlies pour anticiper les évolutions).

Le warning du premier message de conan76 n'est pas une erreur et peut-être ignoré.

-> Si vous voulez de l'aide : il faut passer vos logs en debug, effectuer une action de lecture complète sur un épisode et mettre vos logs sur pastebin pour que l'on regarde.

Membre depuis le 3 November 2009 — 4 messages

@fdonv, merci pour ton retour. Je ferai ça ce soir quand j'aurais accès à ma machine.

J'ai un soupçon que c'est l'auto-update du plugin qui casse tout parce que mes problèmes ont commencé quand il a essayé de passer à la v1.0.8.

Membre depuis le 5 May 2014 — 16 messages

LarrxX a écrit :
@fdonv, merci pour ton retour. Je ferai ça ce soir quand j'aurais accès à ma machine.

J'ai un soupçon que c'est l'auto-update du plugin qui casse tout parce que mes problèmes ont commencé quand il a essayé de passer à la v1.0.8.

Il est fort possible que le problème vienne de l'auto-update effectivement.
Je vais voir avec @ToX69 pour remettre le 1.0.7 par défaut.

Membre depuis le 3 November 2009 — 4 messages

Effectivement, en désactivant l'auto-update et réinstallant l'add-on manuellement, ça marche nickel. 

Membre depuis le 5 May 2014 — 16 messages

la 1.0.8 est bien buguée,
on corrige et remet tout ça nickel d'ici ce weekend.

Membre depuis le 3 November 2009 — 4 messages

Merci d'avance !

Membre depuis le 30 October 2011 — 21 messages

Génial, merci !

Membre depuis le 21 November 2010 — 1 message

j'ai corrige les erreurs de syntaxe de la 1.0.8 (https://gist.github.com/Farigh/364f49a1357b896f0621141ba637e0db si ca peut aider les devs)
ca marche si on désactive les mises a jour auto

edit: javais pas vu le message plus haut... désolé ><

Dernière édition le 20 May 2017 à 01:19

Membre depuis le 28 January 2012 — 4 messages

Farigh a écrit :
j'ai corrige les erreurs de syntaxe de la 1.0.8 (https://gist.github.com/Farigh/364f49a1357b896f0621141ba637e0db si ca peut aider les devs)
ca marche si on désactive les mises a jour auto

edit: javais pas vu le message plus haut... désolé ><

salut Farigh,
tu peux proposer une pull request avec tes corrections! 

Membre depuis le 3 November 2009 — 4 messages

[ Pages : 1 2 3 4 ]

← Page précédente | Page suivante →